Site Map

Back to support

Frequently Asked Questions

Are your plug-ins compatible with OS-X 10.14 Mojave?

Power Suite 5.88 plugs and Master Restoration Suite 5.88 plugs and Dialog 1.37 are NOT fully compatible with Mac OS-X 10.14 Mojave. You will get an “installation error” message when running the plug-in for the first time. Additionally, the AU formats of these plugs are not recognized by the OS, and the plugs do not appear. If you are migrating already installed plug-ins from an earlier OS-X version, they work. We are working to support 10.14.

Tube Saturator 2 and Tube Saturator Vintage work fine on 10.14.